Dienstag, 17. Juli 2012

Upgrade Linux Mint to Maya fails

If Linux Mint Upgrade to Maya fails with the following reason:

/usr/bin/locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /usr/bin/locale)
/usr/bin/locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/bin/locale)
whiptail: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by whiptail)
debconf: whiptail output the above errors, giving up!
dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10_i386.deb (--install):
subprocess new pre-installation script returned error exit status 1
Preparing to replace libc6-dev 2.15-0ubuntu10 (using .../libc6-dev_2.15-0ubuntu10_amd64.deb) ...
Unpacking replacement libc6-dev ...
Preparing to replace libc6-i386 2.15-0ubuntu10 (using .../libc6-i386_2.15-0ubuntu10_amd64.deb) ...
Unpacking replacement libc6-i386 ...
Replaced by files in installed package libc6:i386 ...
dpkg: dependency problems prevent configuration of libc6-dev:
libc6-dev depends on libc6 (= 2.15-0ubuntu10); however:
Version of libc6 on system is 2.13-20ubuntu5.1.
libc6-dev depends on libc-dev-bin (= 2.15-0ubuntu10); however:
Version of libc-dev-bin on system is 2.13-20ubuntu5.1.
dpkg: error processing libc6-dev (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-i386:
libc6-i386 depends on libc6 (= 2.15-0ubuntu10); however:
Version of libc6 on system is 2.13-20ubuntu5.1.
dpkg: error processing libc6-i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.15-0ubuntu10_amd64.deb
/var/cache/apt/archives/libc6_2.15-0ubuntu10_i386.deb
libc6-dev
libc6-i386

  1. Downgrade the following packages
    cd /tmp
    wget http://ftp.halifax.rwth-aachen.de/ubuntu//pool/main/n/newt/libnewt0.52_0.52.11-2ubuntu8_amd64.deb
    wget http://ftp.halifax.rwth-aachen.de/ubuntu//pool/main/n/newt/whiptail_0.52.11-2ubuntu8_amd64.deb
    wget http://ftp.halifax.rwth-aachen.de/ubuntu//pool/main/p/popt/libpopt0_1.16-1_amd64.deb
    sudo dpkg -i libnewt0.52_0.52.11-2ubuntu8_amd64.deb whiptail_0.52.11-2ubuntu8_amd64.deb libpopt0_1.16-1_amd64.deb 
    
  2. Install libc6 and after that resume installation
    dpkg -i /var/cache/apt/archives/libc6*
    apt-get -f install
    

  3. That's it




Kommentare: